黑科技产品HoloLens开发系列教程1
HoloLens
王寒
Apple,SF,Psychology
2人收藏 1353次学习

黑科技产品HoloLens开发系列教程1

原文链接:https://zhuanlan.zhihu.com/p/23224969?refer=kidscoding

说说我初次看到HoloLens的感受吧,xxxxxx这里省略1万个字。

总的来说,就一句话,真TMD黑科技!

好了,废话下次补上,先直入主题吧。

Step1 在自己的电脑上装win10系统,检查硬件配置

我想无论大家之前用的是PC还是MAC,这个条件还是很容易实现的。作为苹果粉丝,之前尝试使用众多VR设备开发都不得不把MAC束之高阁,看到HoloLens对电脑配置要求如此之低,颇有些感动。

虽然理论上说HoloLens的SDK也支持Windows8.x和Windows7,但这都是废话。作为陷坑无数的过来人提醒大家,老老实实装win10吧。别折腾了,有折腾的时间还是来干活做产品比较好。

另外HoloLens Emulator基于Hyper-V,使用RemoteFx提供图像处理的硬件加速。为了保障HoloLens Emulator的正常运行,需要检查PC 是否满足以下硬件配置:

  1. 64位的Windows 10 Pro, Enterprise或Education版

第一个坑来了,Home edition不支持HoloLens Emulator的Hyper-V技术

2. 64位的CPU

3.四核以上的CPU(或者是多个CPU,总共4核以上)

4.8G 以上内存

5.在BIOS中必须支持和开启以下特性:

(1)Hardware-assisted virtualization

(2) Second Level Address Translation(SLAT)

(3)Hardware-based Data Execution Prevention(DEP)

6.GPU

(1)DirectX 11.0或更新版本

(2)WDDM 1.2 或更新版本驱动

如果电脑系统满足以上要求,必须确保开启了“Hyper-V”特性,具体方法如下:

Control Panel(控制面板)->Programs ->Programs and Features -> Turn Windows Features on or off- 确保选中”Hyper-V”.

当然,用bootcamp装了win10系统的Mac电脑用户会遇到一些坑,下面会提到~

Step 2 安装最新版本的Visual Studio

这个没办法,好在现在VS是免费的,所以不存在任何障碍。

不过需要注意的是,开发者必须安装Visual Studio 2015 Update 3,其中带了Windows 10 SDK(版本号1511或更新)。

在安装时,如果选择定制安装,那么一定要选中Universal Windows App Development Tools下面的Tools(1.4) and Windows 10 SDK(10.0.10586).

下载安装地址如下:

Downloads and tools for Windows

Step3 安装HoloLens Emulator(build 10.0.14393.0)

如果你无缘弄一台真正的HoloLens来开发,理论上微软还是提供了一个Emulator(当然,从个人经验来看,就和VR开发类似,不在真机上测试没多大意义,就是过个干瘾,或者方便装B而已。)

Build 10.0.14393.0中包含了HoloLens OS的最新更新。这个安装包里面还包含了HOlographic DirectX 项目模板,可以在Visual Studio中使用。

特别注意:你的电脑必须支持Hyper-V,否则Emulator的安装或者运行会有务无比巨大的坑等着你跳进去。具体参考第一条要求。

下载安装地址:

http://go.microsoft.com/fwlink/?LinkID=823018

当然,这个要求对如今的主流PC来说基本上压力不太大。

然而,作为

Step 4 安装Unity的HoloLens专供技术预览版

目前最新的版本是5.4.0f3 HTP。

对于大多数的开发者来说,如果想要快速为HoloLens开发技术demo拿出去秀,或者是搞个东西出去忽悠客户和投资人,用Unity3d是不二选择。虚幻4引擎的开发者会比较郁闷,因为到目前为止,HoloLens并不支持UE4。

不过,需要提醒大家的是,包括以上所有的下载链接,大家要经常去看看有没有最新的版本。

下载安装地址:

Unity - Microsoft Windows

其它可能的坑:

1.在安装时可能看到错误提示,需要”Visual Studio 2015 Update 1and UWP tools version 1.2”

导致该错误的可能原因有两个:

(1)没有安装Visual Studio 2015 Update 1或更新

解决方法很简单,安装最新的Visual Studio 2015 Update3就好了

(2)虽然装了Visual Studio 2015 Update 1或更新版本,但是没有安装Universal Windows Platform(UWP)tools,手动安装下就好了。

2.可能在安装emulator的时候有错误提示,原因很简单,就是没有启用Hyper-V特性。

总之Mac用户要多加小心~

Step 5.注册成微软的开发者

地址:

developer.microsoft.com

未完待续

加入1KE学习俱乐部

1KE学习俱乐部是只针对1KE学员开放的私人俱乐部
标签:
酷炫 VR